Temporary Fulfillment Delay

Resolved
Degraded performance
Started over 2 years ago Lasted 4 days

Affected

Order Processing
Production & Fulfillment
Updates
  • Resolved
    Resolved

    Our team are back in the Florida factory today and working on all outstanding orders as soon as possible. Please allow another few days for everything to get back up to speed.

    Thanks for your kind messages of support, our team really appreciate you!

  • Identified
    Identified

    Following some confirmed cases of COVID-19, we have taken the decision to close our Florida facility until Monday to ensure the safety of everyone and undertake a deep clean. We're also fortifying our policies and procedures against COVID-19 in order to prevent any unnecessary impacts to production for Valentine's Day

    Orders that are in production currently will ship out early next week. EU or International orders shipping from our Amsterdam facility will ship as normal.

    We thank you and your customers for your understanding at this time.