Domain Verification Delay

Resolved
Degraded performance
Started over 2 years ago Lasted 8 days

Affected

Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Monitoring
    Monitoring

    Our 3rd party vendor has applied a fix, we're monitoring the result. So far, so good. We processed 300+ domains today, please check your inbox/spam for any rejection notices.

  • Identified
    Identified

    We are continuing to work on a fix for this incident with our 3rd party provider.

  • Monitoring
    Monitoring

    We implemented a fix and currently monitoring the result.

  • Identified
    Identified

    We're experiencing a short delay on verifying new custom domains due to fault with a 3rd party vendor. We'll resume domain verification for sellers as soon as the issue is resolved.